GZHU18级寒假训练:Sagittarius's Trial-J

2023-02-19,

POJ-1251(最小生成树)

  • The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

  • Input
    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

  • Output
    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

  • Sample Input
    9
    A 2 B 12 I 25
    B 3 C 10 H 40 I 8
    C 2 D 18 G 55
    D 1 E 44
    E 2 F 60 G 38
    F 0
    G 1 H 35
    H 1 I 35
    3
    A 2 B 10 C 40
    B 1 C 20
    0

  • Sample Output
    216
    30


在网上看到这题可以有两种算法:最小生成树kruskal算法+prim算法。


  • kruskal:
    给假设定一个加权连通图产品 G,G的边集合为E,顶点个数为N,其要求一棵最小生成树 T.
    假设Ť中的边和顶点均涂成红色,其余边为白色。开始时ģ中的边均为白色。
    1)将所有顶点涂成红色;
    2)在白色边中,挑选一条权最小的边,使其与红色边不形成圈,将该白色边涂红;
    3)重复2)直到有n-1个条红色边,这n-1个条红色边便构成最小生成树Ť的边集合。
    注意到在算法执行过程中,顶点红色红色状语从句:边会形成一个或多个连通分支,它们都是ģ的子树。一条边与红色边形成圈当且仅当这条边的两个端点属于同一个子树。因此判定一条边是否与红色边形成圈,只需判断这条边的两端点是否属于同一个子树。
    上述判断可以如此实现:给每个子树一个不同的编号,对每一个顶点引入一个标记T,表示这个顶点所在的子树编号当加入一条红色边,就会使该边两端点所在的两个子树连接起来,成为一个子树,从而两个子树中的顶点标记要改变成一样。综上,可将克鲁斯卡算法细化使其更容易计算机实现。
    的上面方法其实就是不相交集的一种应用,不相交集数据结构提供两种操作查找和联盟,通过查找操作来查看挑选的边得两个顶点是否属于同一子树,如果不属于则将此边放入ŧ中,且对两子树执行联合操作:
    1
    2
    3
    4

    if(Find(i)!=Find(j))
    {
    inserte(i,j)intoT;
    Union(Find(i),Find(j),p);
    }
    有关查找和联盟的具体代码实现和解决克鲁斯卡环去详细的请内容查看不相交集。
    Kruskal算法的时间复杂度由排序算法决定,若采用快速排序算法则时间复杂度为O(N log N)。

  • prim:
    1).输入:一个加权连通图,其中顶点集合为V,边集合为E;
    2).初始化:Vnew = {x},其中x为集合V中的任一节点(起始点),Enew = {},为空;
    3).重复下列操作,直到Vnew = V:
    a.在集合E中选取权值最小的边<u, v>,其中u为集合Vnew中的元素,而v不在Vnew集合当中,并且v∈V(如果存在有多条满足前述条件即具有相同权值的边,则可任意选取其中之一);
    b.将v加入集合Vnew中,将<u, v>边加入集合Enew中;
    4).输出:使用集合Vnew和Enew来描述所得到的最小生成树。

prim
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn = 30;
const int inf = 0x3f3f3f3f;
int road[maxn][maxn], dis[maxn];
bool vis[maxn];
int n;
void prim()
{
    int mi, v;
    for(int i = 0; i < n; i++)
    {
        dis[i] = road[0][i];
        vis[i] = false;
    }
    for(int i = 1; i <= n; i++)//包括第一个点在内,一共要纳入n个点
    {
        mi = inf;
        for(int j = 0; j < n; j++)//每次找出未纳入顶点集与已知顶点集构成的权值最小的一条边
        {
            if(!vis[j] && mi > dis[j])
            {
                v = j;
                mi = dis[j];
            }
        }
        vis[v] = true;//把该顶点纳入已知集合
        for(int j = 0; j < n; j++)//更新与未纳入集合中的顶点的边的最小权值
        {
            if(!vis[j] && dis[j] > road[v][j])
                dis[j] = road[v][j];
        }
    }
    for(int i = 1; i < n; i++)
        dis[0] += dis[i];
    cout << dis[0] << endl;
}
int main()
{
    int m, w;
    char s[5], en[5];
    while(cin >> n, n)
    {
        memset(road, 63, sizeof(road));
        for(int i = 0; i < n; i++)
            road[i][i] = 0;
        for(int i = 1; i < n; i++)
        {
            scanf("%s%d", s, &m);
            for(int j = 0; j < m; j++)
            {
                scanf("%s%d", en, &w);
                road[s[0]-'A'][en[0]-'A'] = road[en[0]-'A'][s[0]-'A'] = w;
            }
        }
        prim();
    }
    return 0;
}

kruskal
#include<iostream>
#include<algorithm>
using namespace std;
int p[27];
struct edge
{
    int villagea;
    int villageb;
    int distance;
}roads[80];
bool cmp(edge a, edge b)
{
    return a.distance < b.distance;
}
int find_ancestor(int x)
{
    return  p[x] == x ? x : p[x] = find_ancestor(p[x]);
}
int main()
{
    int n, k, distance, number, ans;
    char start_village, end_village;
    while(cin >> n, n)
    {
        ans = k = 0;
        for(int i = 0; i < 27; i++)
            p[i] = i;
        for(int i = 0; i < n- 1; i++)
        {
            cin >> start_village >> number;
            for(int j = 0; j < number; j++, k++)
            {
                cin >> end_village >> distance;
                roads[k].villagea = start_village - 'A';
                roads[k].villageb = end_village - 'A';
                roads[k].distance = distance;
            }
        }
        sort(roads, roads + k, cmp);
        for(int i = 0; i < k; i++)
        {
            int x = find_ancestor(roads[i].villagea);
            int y = find_ancestor(roads[i].villageb);
 
            if(x != y)
            {
                ans = ans + roads[i].distance;
                p[y] = x;
            }
        }
        cout << ans << endl;
    }
    return 0;
}

代码源:https://blog.csdn.net/rain722/article/details/54783818